Search found 13 matches

by cpsmusic
Mon Feb 12, 2018 1:19 am
Forum: VST 3 SDK
Topic: Example Plug-ins Not Loading
Replies: 4
Views: 2060

Re: Example Plug-ins Not Loading

Will kindly sent me a couple of plug-ins to test and they work fine. Just wondering if anything in the build output for the SDK looks suspicious: New-MacBook:build chris$ cmake -G"Xcode" "../VST3_SDK" -- The C compiler identification is AppleClang 9.0.0.9000039 -- The CXX compiler identification is ...
by cpsmusic
Sun Feb 11, 2018 2:02 am
Forum: VST 3 SDK
Topic: Example Plug-ins Not Loading
Replies: 4
Views: 2060

Re: Example Plug-ins Not Loading

I've tried rebuilding the SDK but the problem still exists.

Would it be possible for an OS X developer to email me (send me a PM) the again plug-ins. At least then I can see whether the problem is with my setup.

Cheers!
by cpsmusic
Fri Feb 09, 2018 7:44 am
Forum: VST 3 SDK
Topic: Example Plug-ins Not Loading
Replies: 4
Views: 2060

Re: Example Plug-ins Not Loading

Further to this problem, VST3PluginTestHost has the same problem as Studio One 3 - it's only loading the adelay and mda plug-ins.

Any ideas?
by cpsmusic
Thu Feb 08, 2018 12:50 pm
Forum: VST 3 SDK
Topic: Example Plug-ins Not Loading
Replies: 4
Views: 2060

Example Plug-ins Not Loading

Hi,

After building the SDK and installing the example plug-ins Presonus Studio One 3 only loads the adelay and mda plug-ins. All the others are blacklisted (see attached).

This is my environment:
Mac 10.12.6
XCode 9,2
VST SDK 3.6.8
Presonus Studio One 3 3.5.5

How do I fix this?

Cheers,

Chris
by cpsmusic
Tue Dec 19, 2017 12:54 pm
Forum: VSTGUI
Topic: OS X Build Error
Replies: 4
Views: 2562

Re: OS X Build Error

Working now - thanks!
by cpsmusic
Tue Dec 19, 2017 12:46 am
Forum: VSTGUI
Topic: OS X Build Error
Replies: 4
Views: 2562

Re: OS X Build Error

Not sure actually - I grabbed a .zip from the GitHub repo on 14/12.
by cpsmusic
Fri Dec 15, 2017 1:05 pm
Forum: VSTGUI
Topic: OS X Build Error
Replies: 4
Views: 2562

OS X Build Error

Hi, I'm just getting started with VSTGUI. I'm using OS X 10.12.6. When I try to do a build I'm getting the following error: CFrameTest setZoom [OK] -> 630 µs MouseEnterExit [OK] -> 532 µs MouseEnterExitInContainer [OK] -> 104 µs removeViewWhileMouseInside [OK] -> 21 µs focusSettings [OK] -> 80 µs /b...
by cpsmusic
Wed Jun 28, 2017 12:56 am
Forum: VST 3 SDK
Topic: Getting Started - Duplicating an Existing Plug-in Example
Replies: 1
Views: 1517

Getting Started - Duplicating an Existing Plug-in Example

Hi, I've downloaded and built the SDK. I was thinking that the best way to start developing my own plug-in would be to duplicate one of the examples and replace the existing code with my own. What I'm not clear about is how to to do this in Xcode. Say I want to duplicate "again" so that it becomes "...
by cpsmusic
Tue Mar 21, 2017 12:16 pm
Forum: VST 3 SDK
Topic: Beginner Questions - Downloading and Building
Replies: 9
Views: 6293

Re: Beginner Questions - Downloading and Building

Here's what I'm doing: Unzip the SDK cd into VST_SDK cd into VST3_SDK mkdir build cd into build /Applications/CMake.app/Contents/bin/cmake -G"Xcode" "../VST3_SDK" This doesn't seem to create anything? Not sure if I'm creating the "build" directory in the right place or whether I'm running cmake fro...
by cpsmusic
Mon Mar 20, 2017 11:54 pm
Forum: VST 3 SDK
Topic: Beginner Questions - Downloading and Building
Replies: 9
Views: 6293

Re: Beginner Questions - Downloading and Building

Hi, I've run into a build problem using the following instructions: Command line for macOS to build Xcode project: // go in to the folder where you extracted the VST3 SDK >mkdir build >cd build >/Applications/CMake.app/Content/bin/cmake -G"Xcode" "../VST3_SDK" Here's what I'm doing and the error I'...