Search found 28 matches

by rhansen
Tue Oct 06, 2020 7:28 am
Forum: VST 3 SDK
Topic: VST3 Project Generator unable to fully build project
Replies: 4
Views: 94

Re: VST3 Project Generator unable to fully build project

C:\Program Files\CMake\bin\CMake.exe -G "Visual Studio 16 2019" -S "C:/Users/GRT30/Documents/VST Programming stuff/myStuff\AnEffect" -B .. include called with invalid argument: stuff/VST_SDK/VST3_SDK/cmake/modules/SMTG_VST3_SDK.cmake I assume that the spaces in the path to your plug-in might be the...
by rhansen
Wed Sep 09, 2020 2:28 pm
Forum: VST 3 SDK
Topic: smtg_add_plugin_resource inconsistent between platforms
Replies: 5
Views: 2654

Re: smtg_add_plugin_resource inconsistent between platforms

Hey,

the function smtg_add_plugin_resource is designed the way it only takes a relative file path. This makes sense for cross platform development. What is the use case for putting an absolute file path into that function?

Cheers,
René
by rhansen
Wed Mar 18, 2020 7:21 am
Forum: VST 3 SDK
Topic: How do I develop a plugin for Mac (OSX) on Windows?
Replies: 4
Views: 1218

Re: How do I develop a plugin for Mac (OSX) on Windows?

...Do I literally have to build a Mac VST from a Mac computer? That seems highly unlikely... Hey midiosh, yes, you need to build on a mac. Otherwise you need to cross compile. But cross compilation from windows to macos is not possible, never heard of that. Cross compilation does work though with t...
by rhansen
Thu Jun 27, 2019 12:58 pm
Forum: VST 3 SDK
Topic: Resizing plugin not working properly.
Replies: 6
Views: 2136

Re: Resizing plugin not working properly.

Just in case you did not see this yet, here are some sequence diagrams from the SDK: https://steinbergmedia.github.io/vst3_d ... kflow.html - "Resize View Call Sequences" section.

René
by rhansen
Thu Jun 27, 2019 8:28 am
Forum: VST 3 SDK
Topic: Resizing plugin not working properly.
Replies: 6
Views: 2136

Re: Resizing plugin not working properly.

I'm stuck trying to get my plugin to resize properly. I'm using my own gui library, and Reaper x64 for testing. I have a custom View class that inherits from CPluginView, and i have overridden the canResize() and checkSizeConstraint() functions to return true. When the plugin first starts, Reaper's...
by rhansen
Thu Apr 11, 2019 6:24 am
Forum: VST 3 SDK
Topic: VST3 presets show up in Cubase but not Wavelab
Replies: 7
Views: 2144

Re: VST3 presets show up in Cubase but not Wavelab

Nonlinear wrote:Were you able to find out anything about this?
Yes,

definitely a WaveLab "bug". IUnitInfo in combination with IProgramList is not implemented. Unfortunately I cannot tell you when I can do it. But I believe it should be in the next major update of WaveLab.

René
by rhansen
Mon Apr 01, 2019 6:59 am
Forum: VST 3 SDK
Topic: VST3 presets show up in Cubase but not Wavelab
Replies: 7
Views: 2144

Re: VST3 presets show up in Cubase but not Wavelab

Nonlinear wrote: Are you suggesting this may be a problem in Wavelab and you can fix it?
Yes ;)

I will come back to you after I had a closer look.

René
by rhansen
Thu Mar 28, 2019 1:23 pm
Forum: VST 3 SDK
Topic: VST3 presets show up in Cubase but not Wavelab
Replies: 7
Views: 2144

Re: VST3 presets show up in Cubase but not Wavelab

I have program presets hard-coded into my plugin (legacy VST2 style) and I'm curious why they show up in Cubase but not Wavelab? The only thing that shows up in the presets menu in Wavelab is the "Default" preset. If there's a problem in my code why does it work right in Cubase and other VST3 hosts...
by rhansen
Tue Oct 30, 2018 8:56 am
Forum: VST 3 SDK
Topic: Compiling on linux - required packages
Replies: 2
Views: 1228

Re: Compiling on linux - required packages

A list of packages would be good to add to the readme! This is what I installed on Ubuntu 18.04: libx11-xcb-dev libxcb-util-dev libxcb-cursor-dev libxcb-xkb-dev libxkbcommon-dev libxkbcommon-x11-dev libfontconfig1-dev libcairo2-dev libgtkmm-3.0-dev libsqlite3-dev libxcb-keysyms1-dev Will be added t...
by rhansen
Tue Jun 26, 2018 12:59 pm
Forum: VSTGUI
Topic: Plugin crashes in Windows high-DPI mode
Replies: 7
Views: 3438

Re: Plugin crashes in Windows high-DPI mode

bx_joscha wrote:Probably, the Wavelab bug is also a host problem.
I will investigate this. Can you please tell me the WaveLab version you are using?

René