Search found 118 matches

by pongasoft
Wed Mar 14, 2018 6:03 pm
Forum: VSTGUI
Topic: [Solved] editorhost COnOffButton not working
Replies: 9
Views: 3804

Re: editorhost COnOffButton not working

I found out what the problem is: when looking at the helloworld_with_VSTGUI project now provided with SDK 3.6.9 I saw that there was the same file with different names: background.png, background_2x.png, background_3x.png which led me to believe that somehow the name of the bitmap contains the resol...
by pongasoft
Tue Mar 13, 2018 6:21 pm
Forum: VSTGUI
Topic: [Solved] editorhost COnOffButton not working
Replies: 9
Views: 3804

Re: editorhost COnOffButton not working

Arne Scheffler wrote:Do you have the following output in the debugger console ?

Code: Select all

*** Bitmap 'Control_AudioSwitch_50x100.png' not found.
No, it just get loaded fine. No error message.

Yan
by pongasoft
Tue Mar 13, 2018 6:19 pm
Forum: VST 3 SDK
Topic: cmake command line build broken in 369
Replies: 4
Views: 1981

Re: cmake command line build broken in 369

Thank you for your quick response. While looking at the cmake/modules/AddVST3Library.cmake file that you were pointing out I realized what is in fact broken... This is what 3.6.8 was doing: # Run the validator after building function(smtg_run_vst_validator target) add_dependencies(${target} validato...
by pongasoft
Tue Mar 13, 2018 2:24 pm
Forum: VSTGUI
Topic: [Solved] editorhost COnOffButton not working
Replies: 9
Views: 3804

Re: editorhost COnOffButton not working

Arne Scheffler wrote:I think the bitmap have to be next to the xml file to be found.
It is. Both files are in the SAME folder. Exactly like in the again example...

Yan
by pongasoft
Tue Mar 13, 2018 2:03 pm
Forum: VSTGUI
Topic: [Solved] editorhost COnOffButton not working
Replies: 9
Views: 3804

Re: editorhost COnOffButton not working

Hi, please save the xml file first, then add the xml file to your cmake or Xcode project and rebuild. After that it hopefully should work. Cheers Arne I followed your suggestion and it does not work. It is still the same issue. When looking at the xml file, it does seem "right" to me: ... <view bac...
by pongasoft
Mon Mar 12, 2018 6:39 pm
Forum: VSTGUI
Topic: [Solved] editorhost COnOffButton not working
Replies: 9
Views: 3804

[Solved] editorhost COnOffButton not working

Hello I am new to this so I apologize if I am doing something wrong. I created a blank plugin (no xml file). I then right click to enter the editor (I use the editorhost app provided). I added a text field (CTextLabel). I then wanted to add a COnOffButton to represents a toggle with 2 values. I adde...
by pongasoft
Mon Mar 12, 2018 4:40 pm
Forum: VST 3 SDK
Topic: cmake command line build broken in 369
Replies: 4
Views: 1981

Re: cmake command line build broken in 369

Unfortunately that will not help me. I am not a fan of generating an Xcode project and work of it because I want my source of truth to be the cmake files so that I can do cross platform. I actually use CLion which work directly off the CMakeLists.txt and so the build is broken (works with 368). Is t...
by pongasoft
Mon Mar 12, 2018 3:20 pm
Forum: VST 3 SDK
Topic: cmake command line build broken in 369
Replies: 4
Views: 1981

cmake command line build broken in 369

Hello I just upgraded to 369 and the cmake command line build no longer works. I am on Mac 10.13.3. Xcode 9.2. cmake 3.9.4 Here is how to reproduce: With vst368 => works > mkdir vst368 > cd vst368 > cmake -DCMAKE_BUILD_TYPE=Debug /Volumes/Vault/Applications/VST_SDK.368/VST3_SDK -- The C compiler ide...