Search found 67 matches

by willpirkle
Thu May 11, 2017 9:18 pm
Forum: VST 3 SDK
Topic: Logging to stderr on Mac?
Replies: 2
Views: 1992

Re: Logging to stderr on Mac?

Hey Howard: I don't have any problems with fprintf(stderr,...) on XCode with VST3 clients, however Pro Tools will prevent stderr and stdout from appearing (which sounds like what you may be experiencing). I got a great tip from a friend at SoundToys who uses Terminal for all logging. You start the c...
by willpirkle
Mon Apr 03, 2017 4:21 pm
Forum: VST 3 SDK
Topic: Vst2 Wrapper VST 3.6.7 crashes hosts on Windows.
Replies: 6
Views: 3470

Re: Vst2 Wrapper VST 3.6.7 crashes hosts on Windows.

This is happening for me as well - just tried it. Adding the second instance as VST crashes the host. It does not halt when running in the debugger, though, just crashes the host. I tried with Reaper and Cubase 7 and both crash when you add the second instance. Also tried Reaper 32 and Reaper 64 wit...
by willpirkle
Mon Apr 03, 2017 1:26 pm
Forum: VST 3 SDK
Topic: [Solved] VST2 not detected by Live with SDK 3.6.7
Replies: 30
Views: 14812

Re: VST2 not detected by Live with SDK 3.6.7

I just re-read your original post on this. When using the VST2 wrapper, I've found the following: renaming the .vst3 plugin to .dll works on Windows to turn it into a vst2 plugin. Renaming the .vst3 to .vst does NOT work for me on MacOS. I need to compile a separate target for VST2 on MacOS and gene...
by willpirkle
Mon Mar 27, 2017 8:21 pm
Forum: VSTGUI
Topic: CNewFileSelector crash, MacOS
Replies: 3
Views: 2878

Re: CNewFileSelector crash, MacOS

Hi Arne

Thanks for checking it - right now it is not a problem to leave out the call to setDefaultExtension( ) so it is still workable. If it changes with the next Mac/XCode I get, I will post it.

- Will
by willpirkle
Fri Mar 24, 2017 11:57 am
Forum: VST 3 SDK
Topic: [Solved] VST2 not detected by Live with SDK 3.6.7
Replies: 30
Views: 14812

Re: VST2 not detected by Live with SDK 3.6.7

OK, false alarm for me.

My VST2 had been black-listed in Ableton, from when I was testing it as a 32-bit plugin.

Removing it, restarting, replacing it, restarting again, fixed the problem with Ableton. Sorry for the false alarm - my bad.

- Will
by willpirkle
Thu Mar 23, 2017 8:28 pm
Forum: VST 3 SDK
Topic: [Solved] VST2 not detected by Live with SDK 3.6.7
Replies: 30
Views: 14812

Re: VST2 not detected by Live with SDK 3.6.7

I'm not seeing the VST2 version of again in Bitwig or Reaper. I think what you are seeing is the VST3 version. I'm not using again, it is my own plugin that is built externally from the SDK samples and it builds two different targets, one VST3 and the other VST2. The VST2 version is for sure showin...
by willpirkle
Thu Mar 23, 2017 3:05 pm
Forum: VST 3 SDK
Topic: SDK 3.6.7 and XCode 6 Issues/Errors/Fixes
Replies: 6
Views: 3512

Re: SDK 3.6.7 and XCode 6 Issues/Errors/Fixes

That makes sense - ugh - now I need to get a new Mac... :(
by willpirkle
Thu Mar 23, 2017 3:02 pm
Forum: VST 3 SDK
Topic: [Solved] VST2 not detected by Live with SDK 3.6.7
Replies: 30
Views: 14812

Re: VST2 not detected by Live with SDK 3.6.7

Here is what mine looks like (VTestA.vst) nm VTestA.vst/Contents/MacOS/VTestA | grep Main U _CFRunLoopGetMain 0000000000010000 T _VSTPluginMain 0000000000481928 s __ZN6VSTGUI13MainNodeNamesL11kControlTagE 00000000004818e8 s __ZN6VSTGUI13MainNodeNamesL5kFontE 00000000004818f0 s __ZN6VSTGUI13MainNodeN...
by willpirkle
Thu Mar 23, 2017 2:01 pm
Forum: VST 3 SDK
Topic: [Solved] VST2 not detected by Live with SDK 3.6.7
Replies: 30
Views: 14812

Re: VST2 not detected by Live with SDK 3.6.7

I am also seeing this as well with my own plugins that use the VST2 wrapper + SDK 3.6.7. Ableton Live 9 does not see or list them, however Reaper and Bitwig do see them, and they work properly, and the GUI shows correctly. XCode6 MacOS 10.9.5 SDK 3.6.7 Compiling as 64-bit Ableton Live 9, Reaper 5.24...
by willpirkle
Thu Mar 23, 2017 1:23 pm
Forum: VST 3 SDK
Topic: SDK 3.6.7 and XCode 6 Issues/Errors/Fixes
Replies: 6
Views: 3512

Re: SDK 3.6.7 and XCode 6 Issues/Errors/Fixes

Hi Arne

Thanks for the reply - I forgot to mention that I did set the editorhost project to C++11. I am thinking this is XCode6 related.
Screen Shot 2017-03-23 at 8.55.27 AM.png
- Will