Recording Error: ASIO driver is not running.

Audio Stream Input/Output (ASIO) is a protocol allowing communication between a software application and a computer's sound card.
hagen
Posts: 2
Joined: Mon Dec 04, 2017 1:44 pm

Recording Error: ASIO driver is not running.

Postby hagen » Mon Dec 04, 2017 2:35 pm

Hi Steinbergs,
I hope this is the right place as this board doesn't seem to be too vidid. Please advice else...!

I am finalizing my ASIO driver connected to some PCIe interface. It seems to work with all major DAWs (Reaper, Studio One, Ableton, ProTools) except with the mother of ASIO, Cubase. (Cubase 9 doesn't complain about anything, it advances the playback pointer, but the buffers aren't filled and no meter activity can be seen on the GUI.)

I am a bit puzzled to what else I could check, I am calling the bufferSwitch* callback, checked the sample position calculation, timestamps, etc. I do see all ASIO::methods get reasonably interrogated (except getSampleRate() which get constantly called?).

If I try to arm some channels for recording Cubase opens a MessageBox claiming "Recording Error: ASIO driver is not running."

Any pointers what else to check would be greatly appreciated!
Thanks,
Hagen.

hagen
Posts: 2
Joined: Mon Dec 04, 2017 1:44 pm

Re: Recording Error: ASIO driver is not running.

Postby hagen » Mon Dec 04, 2017 10:39 pm

Issue was related to ASIOSamples and ASIOTimeStamp being hi/lo word swapped (like big endian, but with little endian byte ordering in the words itself).

Gut, kann man auch machen.

Cheers,
Hagen.


Return to “ASIO”

Who is online

Users browsing this forum: No registered users and 1 guest