Windows 64bits GUI very slow after updating to 4.3

A user interface toolkit mainly for audio plug-ins (VST, AudioUnit, etc).
Post Reply
xavier
Posts: 9
Joined: Thu Jul 21, 2016 9:46 am

Windows 64bits GUI very slow after updating to 4.3

Post by xavier »

Hi,

I updated a product from VSTGUI 3.6 to VSTGUI 4.3 on windows, built with Visual Studio 2008.
It's working fine on 32 bits, but when I launch a 64 bits application in windows7, the GUI is terribly slow.
I did the same on OSX without any problems.

I bet it's related to some build parameters, Visual Studio version or graphic framework, but I can't find any real clue or hint.
Can VSTGUI 4.3 be built with Studio 2008 ? Should I install something on windows 7 and ask users to do so ? Should I install something aside Studio 2008 for building it with that ?

Thanks in advance for your help.

Best regards
Xavier

Arne Scheffler
Posts: 354
Joined: Mon Jun 20, 2016 7:53 am

Re: Windows 64bits GUI very slow after updating to 4.3

Post by Arne Scheffler »

Hi,
normally there shouldn't be any differences between 32 and 64 bit. Can you explain what exactly is slow on 64 bit ? Can you make a video ?

Cheers
Arne

xavier
Posts: 9
Joined: Thu Jul 21, 2016 9:46 am

Re: Windows 64bits GUI very slow after updating to 4.3

Post by xavier »

Hi,
Thanks for your fast answer

I did something (I can' show you everything here, it's still a new confidential product for a few weeks. But I can send you more privately)

https://www.xils-lab.com/perso/SlugghishGUI4.3.m4v

It's very rough video, but you will see (windows 7, 64 bits, Cubase 7):
_ All working fine when the GUI is closed
_ Opening the GU, all is stuck
_ Then, you can see how the mouse is very very slow, the graphic doesn't correspond to the Audio as it should
_ Clicking on a note, you er the sound, but the image is updated long after

In fact there is no real differences between 32 and 64 bits : both are slow, but 32 bits is usable, 64 bits absolutely not.

Thanks again for your help

Best regards
Xavier

Arne Scheffler
Posts: 354
Joined: Mon Jun 20, 2016 7:53 am

Re: Windows 64bits GUI very slow after updating to 4.3

Post by Arne Scheffler »

OK, not much I can see, but I guess that you are redrawing your whole editor all the time.This is much worse on Windows as on macOS as macOS throttles redraws to 60 or 30Hz, while Windows does not do this. Another thing you should do is eliminate every offscreen buffer you have introduced yourself to reduce flicker in VSTGUI3.6. This is not necessary any more and handled by VSTGUI itself. You need a profiler to see what is going on.

Cheers
Arne

xavier
Posts: 9
Joined: Thu Jul 21, 2016 9:46 am

Re: Windows 64bits GUI very slow after updating to 4.3

Post by xavier »

Thanks Arne

I will check that this WE.
Normally only a few container are redrawn totally. But as the keyboard in one of them and quite bi, that could explain it

Best regards
Xavier

Post Reply