SDK3.6.12 and VS2015 - confirmation that it is not supported

SDK for VST 3 audio plug-in and host development.
Post Reply
willpirkle
Posts: 54
Joined: Tue Jun 21, 2016 12:53 pm

SDK3.6.12 and VS2015 - confirmation that it is not supported

Post by willpirkle » Sat Dec 29, 2018 9:29 pm

The VST3 SDK 3.6.12 GitHub page lists VS2015 and VS2017 as supported compilers, but I am only able to get VS2017 to work with the sample plugins in the SDK. VS2015 throws numerous errors at what appears to be new C++ extensions (I didn't investigate this very deeply after I saw VS2017 compile it without issues). There was no information on the Forum topic here either: viewtopic.php?f=4&t=622

Could you please confirm that VS2015 will not work with the SDK 3.6.12? This is only for some technical documentation and I want to make sure I have the correct information.

If VS2015 is supported, is there a minimum version or service pack that is required?

My version is VS2015 Community 14.0.25431.01 Update 3.

Thanks,

Will

Ry-Fi
Posts: 1
Joined: Thu Jan 03, 2019 4:14 pm

Re: SDK3.6.12 and VS2015 - confirmation that it is not supported

Post by Ry-Fi » Fri Jan 04, 2019 5:01 pm

Hey Will,

I can corroborate that VS2015 doesn't build 3.6.12 out of the box. But I think there was only one place that I had to change that must've been using C++14 syntax that VS2015 couldn't deal with, and then another place where there was a namespace conflict or ambiguity and I had to remedy that, but I've already forgotten the details of exactly what I had to do.

But yes, confirmed that VS2015 does NOT build straight out of the box.

Ryan

willpirkle
Posts: 54
Joined: Tue Jun 21, 2016 12:53 pm

Re: SDK3.6.12 and VS2015 - confirmation that it is not supported

Post by willpirkle » Sat Jan 05, 2019 12:15 am

Thanks for confirming, Ryan. Much appreciated!

- Will

Post Reply